Disruption with billing information updates

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Sep 24, 2026 - 20:41 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted Sep 24, 2026 - 20:24 UTC

Update

We have applied the mitigation and are seeing signs of recovery. We are continuing to monitor the system closely.
Posted Sep 24, 2026 - 20:10 UTC

Update

We are continuing to work on mitigation. We will post another update in approximately one hour.
Posted Sep 24, 2026 - 18:22 UTC

Update

We have identified the problem and are actively working on mitigation.
Posted Sep 24, 2026 - 17:40 UTC

Update

We are investigating failures on billing information updates. Customers may be unable to create or update their billing information in the meantime.
Posted Sep 24, 2026 - 16:51 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Sep 24, 2026 - 16:51 UTC