Actions Workflows Run Start Delays

Incident Report for GitHub

Resolved

On Jan 28, 2026, between 14:56 UTC and 15:44 UTC, GitHub Actions experienced degraded performance. During this time, workflows experienced an average delay of 49 seconds, and 4.7% of workflow runs failed to start within 5 minutes. The root cause was an atypical load pattern that overwhelmed system capacity and caused resource contention.

Recovery began once additional resources came online at 15:25 UTC, with full recovery at 15:44 UTC. We are implementing safeguards to prevent this failure mode and enhancing our monitoring to detect and address similar patterns more quickly in the future.
Posted Jan 28, 2026 - 15:54 UTC

Update

Actions workflow run starts are delayed. We are actively investigating to find a mitigation.
Posted Jan 28, 2026 - 15:37 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jan 28, 2026 - 15:12 UTC
This incident affected: Actions.