Disruption with GitHub Billing

Incident Report for GitHub

Update

We are continuing to monitor the mitigation that we have applied for the billing page disruption.
Posted Aug 27, 2026 - 01:35 UTC

Update

We've applied a mitigation to unblock Copilot usage and have observed recovery for this particular impact. We're continuing to investigate and apply mitigations for the billing page disruption while monitoring to ensure Copilot remains recovered.
Posted Aug 27, 2026 - 00:31 UTC

Update

We are currently investigating increased errors with billing services. Customers may observe failed billing budget page loads, and users of the Copilot CLI may observe failures starting or continuing sessions.
Posted Aug 26, 2026 - 23:42 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Aug 26, 2026 - 23:37 UTC