Incident with Packages

Incident Report for GitHub

Resolved

On August 14, 2025, between 17:50 UTC and 18:08 UTC, the Packages NPM Registry service was degraded. During this period, NPM package uploads were unavailable and approximately 50% of download requests failed. We identified the root cause as a sudden spike in Packages publishing activity that exceeded our service capacity limits. We are implementing better guardrails to protect the service against unexpected traffic surges and improving our incident response runbooks to ensure faster mitigation of similar issues.
Posted Aug 14, 2025 - 18:37 UTC

Update

The NPM registry has now returned to normal functioning.
Posted Aug 14, 2025 - 18:37 UTC

Update

The NPM registry service is currently experiencing intermittent availability issues. Other package registries should be unaffected. Investigations are ongoing.
Posted Aug 14, 2025 - 18:11 UTC

Investigating

We are investigating reports of degraded performance for Packages
Posted Aug 14, 2025 - 18:06 UTC
This incident affected: Packages.