Disruption with some GitHub services

Incident Report for GitHub

Resolved

On August 11, 2025, from 18:41 to 18:57 UTC, GitHub customers experienced errors and increased latency when loading GitHub’s web interface. During this time, a configuration change to improve our UI deployment system caused a surge in requests to a backend datastore. This change led to an unexpected spike in connection attempts to our datastore and saturated its connection backlog and resulted in intermittent failures to serve required UI content. This resulted in elevated error rates for frontend requests.

The incident was mitigated by reverting the configuration, which restored normal service.

Following mitigation, we are evaluating improvements to our alerting thresholds and exploring architectural changes to reduce load to this datastore and improve the resilience of our UI delivery pipeline.
Posted Aug 11, 2025 - 18:57 UTC

Update

Logged out users may see intermittent errors when loading github.com webpages. Investigation is ongoing.
Posted Aug 11, 2025 - 18:53 UTC

Investigating

We are currently investigating this issue.
Posted Aug 11, 2025 - 18:51 UTC