Incident with Actions

Incident Report for GitHub

Resolved

On June 5th, 2025, between 17:47 UTC and 19:20 UTC the Actions service was degraded, leading to run start delays and intermittent job failures. During this period, 47.2% of runs had delayed starts, and 21.0% of runs failed. The impact extended beyond Actions itself - 60% of Copilot Coding Agent sessions were cancelled, and all Pages sites using branch-based builds failed to deploy (though Pages serving remained unaffected). The issue was caused by a spike in load between internal Actions services exposing a misconfiguration that caused throttling of requests in the critical path of run starts. We mitigated the incident by correcting the service configuration to prevent throttling and have updated our deployment process to ensure the correct configuration is preserved moving forward.
Posted Jun 05, 2025 - 19:29 UTC

Update

We have applied a mitigation and we are beginning to see recovery. We are continuing to monitor for recovery.
Posted Jun 05, 2025 - 19:02 UTC

Update

Actions is experiencing degraded availability. We are continuing to investigate.
Posted Jun 05, 2025 - 18:35 UTC

Update

Users of Actions will see delays in jobs starting or job failures. Users of Pages will see slow or failed deployments
Posted Jun 05, 2025 - 18:30 UTC

Update

Pages is experiencing degraded performance. We are continuing to investigate.
Posted Jun 05, 2025 - 18:01 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jun 05, 2025 - 18:00 UTC
This incident affected: Actions and Pages.