On February 2, 2026, GitHub Codespaces were unavailable between 18:55 and 22:20 UTC and degraded until the service fully recovered at February 3, 2026 00:15 UTC. During this time, Codespaces creation and resume operations failed in all regions.
This outage was caused by a backend storage access policy change in our underlying compute provider that blocked access to critical VM metadata, causing all VM create, delete, reimage, and other operations to fail. More information is available at https://azure.status.microsoft/en-us/status/history/?trackingId=FNJ8-VQZ. This was mitigated by rolling back the policy change, which started at 22:15 UTC. As VMs came back online, our runners worked through the backlog of requests that hadn’t timed out.
We are working with our compute provider to improve our incident response and engagement time, improve early detection before they impact our customers, and ensure safe rollout should similar changes occur in the future. We recognize this was a significant outage to our users that rely on GitHub’s workloads and apologize for the impact this had.
Posted Feb 03, 2026 - 00:54 UTC
Update
Codespaces is operating normally.
Posted Feb 03, 2026 - 00:54 UTC
Update
Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Feb 03, 2026 - 00:25 UTC
Update
Codespaces is seeing steady recovery
Posted Feb 02, 2026 - 23:52 UTC
Update
Users may see errors creating or resuming codespaces. We are investigating and will provide further updates as we have them.
Posted Feb 02, 2026 - 20:19 UTC
Investigating
We are investigating reports of degraded availability for Codespaces